# Keycloak won't start with H2 cluster: Error while creating file keycloak.trace.db

**URL:** <https://forum.keycloak.org/t/keycloak-wont-start-with-h2-cluster-error-while-creating-file-keycloak-trace-db/11954>\
**Category:** Configuring the server\
**Tags:** clustering\
**Created:** [November 8, 2021, 4:37pm UTC](https://forum.keycloak.org/t/keycloak-wont-start-with-h2-cluster-error-while-creating-file-keycloak-trace-db/11954 "2021-11-08T16:37:36Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![HoangAlain](https://avatars.discourse-cdn.com/v4/letter/h/13edae/32.png) [@HoangAlain](https://forum.keycloak.org/u/HoangAlain)\
**Post date:** [November 8, 2021, 4:37pm UTC](https://forum.keycloak.org/t/keycloak-wont-start-with-h2-cluster-error-while-creating-file-keycloak-trace-db/11954/1 "2021-11-08T16:37:36Z")

</div>

Hello,

I did install keycloak 11.0.3 on 2 RHEL 7.9 VMs.  
to have it in cluster, I did started 2 H2 processes on 2 VMs:

java -classpath /opt/keycloak-11.0.3/modules/system/layers/base/com/h2database/h2/main/h2-1.4.197.jar org.h2.tools.Server -tcp -tcpAllowOthers -tcpPort 9889 -baseDir /opt/keycloak-11.0.3/server

then I did create an H2 cluster:

java -classpath /opt/keycloak-11.0.3/modules/system/layers/base/com/h2database/h2/main/h2-1.4.197.jar org.h2.tools.CreateCluster -urlSource jdbc:h2:tcp://10.86.76.120:9889/keycloak -urlTarget jdbc:h2:tcp://10.86.76.121:9889/keycloak -user sa -serverList 10.86.76.120:9889,10.86.76.121:9889

then I did modify standalone-ha.xml to use it:

```
                <connection-url>jdbc:h2://10.86.76.120:9889,10.86.76.121:9889/keycloak;AUTO_SERVER=TRUE</connection-url>
                <driver>h2</driver>
                <security>
                    <user-name>sa</user-name>
                    <!-- <password>sa</password> -->
                </security>

```

but when I start keycloak, I’m getting this error in server.log:

(ServerService Thread Pool – 61) org.h2.message.DbException: Log file error: “/10.86.76.120:9889,10.86.76.121:9889/keycloak.trace.db”, cause: “org.h2.message.DbException: Error while creating file “”/10.86.76.120:9889,10.86.76.121:9889"” [90062-197]" [90034-197]

in H2 directory, I do see only keyclook.mv.db file:

# ls -l ../../server

total 16  
-rw-r–r-- 1 root root 16384 Nov 8 11:07 keycloak.mv.db

I’m doing same configuration as I did on 2 other platforms.. but it does fail on this one… ☹  
what did I miss?  
Any tip?

See you,  
Alain.
