# Keycloak suddenly can't connect to mysql javax.resource.ResourceException: IJ031084: Unable to create connection

**URL:** <https://forum.keycloak.org/t/keycloak-suddenly-cant-connect-to-mysql-javax-resource-resourceexception-ij031084-unable-to-create-connection/6459>\
**Category:** Miscellanaeous\
**Created:** [December 17, 2020, 5:41pm UTC](https://forum.keycloak.org/t/keycloak-suddenly-cant-connect-to-mysql-javax-resource-resourceexception-ij031084-unable-to-create-connection/6459 "2020-12-17T17:41:28Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![dwschulze](https://yyz2.discourse-cdn.com/free1/user_avatar/forum.keycloak.org/dwschulze/32/1891_2.png) [@dwschulze](https://forum.keycloak.org/u/dwschulze)\
**Post date:** [December 17, 2020, 5:41pm UTC](https://forum.keycloak.org/t/keycloak-suddenly-cant-connect-to-mysql-javax-resource-resourceexception-ij031084-unable-to-create-connection/6459/1 "2020-12-17T17:41:28Z")

</div>

I was running keycloak in docker all day yesterday at the office using these commands:

docker network create keycloak-network  
docker run --name mysql -d --net keycloak-network -e MYSQL\_DATABASE=keycloak -e MYSQL\_USER=keycloak -e MYSQL\_PASSWORD=password -e MYSQL\_ROOT\_PASSWORD=root\_password mysql  
docker run -d -it -e KEYCLOAK\_USER=admin -e KEYCLOAK\_PASSWORD=admin --name keycloak --net keycloak-network -p 8080:8080 jboss/keycloak

When I got home the keycloak started failing with

/opt/jboss/tools/docker-entrypoint.sh: line 165: DB\_ADDR: unbound variable

I added the DB\_ADDR env var

docker run -e DB\_ADDR=mysql -e KEYCLOAK\_USER=admin -e KEYCLOAK\_PASSWORD=admin --name keycloak --net keycloak-network -p 8080:8080 jboss/keycloak:11.0.3

and it fails with

javax.resource.ResourceException: IJ031084: Unable to create connection

I’ve tried rolling back to 11.0.3 (version 12 was released yesterday) and tried adding

-e JDBC\_PARAMS=useSSL=false

but still get the same error.

The only thing I can think of that changed was moving from my work network to my home network, but I can’t understand why that would be a problem when mysql and keycloak both run on the same docker network.

Is anyone else seeing this?

---

<div class="post-metadata">

**Author:** ![dwschulze](https://yyz2.discourse-cdn.com/free1/user_avatar/forum.keycloak.org/dwschulze/32/1891_2.png) [@dwschulze](https://forum.keycloak.org/u/dwschulze)\
**Post date:** [December 17, 2020, 11:40pm UTC](https://forum.keycloak.org/t/keycloak-suddenly-cant-connect-to-mysql-javax-resource-resourceexception-ij031084-unable-to-create-connection/6459/2 "2020-12-17T23:40:48Z")

</div>

I was able to get this to work by using -e DB\_VENDOR=mysql
