# Keycloak log level update during runtime

**URL:** <https://forum.keycloak.org/t/keycloak-log-level-update-during-runtime/24933>\
**Category:** Getting advice\
**Tags:** client-configuration\
**Created:** [March 7, 2024, 9:42am UTC](https://forum.keycloak.org/t/keycloak-log-level-update-during-runtime/24933 "2024-03-07T09:42:04Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![sathyavathy1](https://avatars.discourse-cdn.com/v4/letter/s/aeb1de/32.png) [@sathyavathy1](https://forum.keycloak.org/u/sathyavathy1)\
**Post date:** [March 7, 2024, 9:42am UTC](https://forum.keycloak.org/t/keycloak-log-level-update-during-runtime/24933/1 "2024-03-07T09:42:04Z")

</div>

Hello All,

I’m trying to update/change keycloak log level when my keycloak container is running.  
I’m getting the below error, please provide your guidance on the same.

$ /opt/bitnami/keycloak/bin/kc.sh start --log-level=DEBUG  
Appending additional Java properties to JAVA\_OPTS: ‘-Djdk.security.allowNonCaAnchor=true’  
ERROR: transport error 202: bind failed: Address already in use  
ERROR: JDWP Transport dt\_socket failed to initialize, TRANSPORT\_INIT(510)  
JDWP exit error AGENT\_ERROR\_TRANSPORT\_INIT(197): No transports initialized [src/jdk.jdwp.agent/share/native/libjdwp/debugInit.c:744]

---

<div class="post-metadata">

**Author:** ![belfhi](https://yyz2.discourse-cdn.com/free1/user_avatar/forum.keycloak.org/belfhi/32/1690_2.png) [@belfhi](https://forum.keycloak.org/u/belfhi)\
**Post date:** [March 11, 2024, 8:33am UTC](https://forum.keycloak.org/t/keycloak-log-level-update-during-runtime/24933/2 "2024-03-11T08:33:09Z")

</div>

Hi @sathyavathy1 ,  
Since the loglevel is a command line argument at startup it can’t be changed during runtime.  
I would run Keycloak with more than 1 replica (e.g. with docker compose) and then do a rolling update  
of the containers with new loglevels.  
That way you can achieve changes without a downtime to your Keycloak Service.
